]> git.pld-linux.org Git - packages/perl-Module-Build-Tiny.git/blob - perl-Module-Build-Tiny.spec
- updated to 0.047
[packages/perl-Module-Build-Tiny.git] / perl-Module-Build-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build-Tiny
7 Summary:        Module::Build::Tiny - A tiny replacement for Module::Build
8 Summary(pl.UTF-8):      Module::Build::Tiny - mały zamiennik systemu Module::Build
9 Name:           perl-Module-Build-Tiny
10 Version:        0.047
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  de9814b3c22825837438fc70adad58ac
17 URL:            https://metacpan.org/release/Module-Build-Tiny
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-ExtUtils-Config >= 0.003
24 BuildRequires:  perl-ExtUtils-Helpers >= 0.020
25 BuildRequires:  perl-ExtUtils-InstallPaths >= 0.002
26 BuildRequires:  perl-Test-Harness >= 3.30
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Many Perl distributions use a Build.PL file instead of a Makefile.PL
33 file to drive distribution configuration, build, test and
34 installation. Traditionally, Build.PL uses Module::Build as
35 the underlying build system. This module provides a simple,
36 lightweight, drop-in replacement.
37
38 Whereas Module::Build has over 6,700 lines of code; this module has
39 less than 120, yet supports the features needed by most distributions.
40
41 %description -l pl.UTF-8
42 Wiele pakietów perlowych wykorzystuje plik Build.PL zamiast pliku
43 Makefile.PL do sterowania konfiguracją, budowaniem, testowaniem i
44 instajacją. Tradycyjnie Build.PL w roli systemu budującego
45 wykorzystuje Module::Build; ten moduł dostarcza prosty, lekki
46 zamiennik.
47
48 O ile Module::Build ma ponad 6700 linii kodu, ten moduł ma mniej niż
49 120, a obsługuje funkcje wymaganych przez większość pakietów.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %{__sed} -i -e 's/.*in blib is readonly.*/#&/g' t/simple.t
55
56 %build
57 %{__perl} Build.PL \
58         --installdirs=vendor
59 ./Build
60
61 %{?with_tests:./Build test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 ./Build install \
67         --destdir=$RPM_BUILD_ROOT \
68         --create_packlist=0
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes INSTALL README
76 %dir %{perl_vendorlib}/Module/Build
77 %{perl_vendorlib}/Module/Build/Tiny.pm
78 %{_mandir}/man3/Module::Build::Tiny.3pm*
This page took 0.079026 seconds and 4 git commands to generate.