]> git.pld-linux.org Git - packages/perl-Module-Build-Deprecated.git/blob - perl-Module-Build-Deprecated.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Build-Deprecated.git] / perl-Module-Build-Deprecated.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build-Deprecated
7 Summary:        Module::Build::Deprecated - A collection of modules removed from Module-Build
8 Summary(pl.UTF-8):      Module::Build::Deprecated - zbiór modułów usuniętych z Module-Build
9 Name:           perl-Module-Build-Deprecated
10 Version:        0.4210
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0e6e5f4f27f0ea6990f29f6e10aa65e6
17 URL:            http://search.cpan.org/dist/Module-Build-Deprecated/
18 BuildRequires:  perl-Module-Build >= 0.3601
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-CPAN-Meta-YAML >= 0.002
23 BuildRequires:  perl-Module-Metadata
24 BuildRequires:  perl-Test-Simple
25 BuildRequires:  perl-version >= 0.87
26 %endif
27 Requires:       perl-Module-Build >= 0.4210
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module contains a number of module that have been removed from
33 Module-Build: ModuleInfo, Version and YAML.
34
35 %description -l pl.UTF-8
36 Ten moduł zawiera zbiór modułów, które zostały usunięte z dystrybucji
37 Module-Build: ModuleInfo, Version oraz YAML.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Build.PL \
44         destdir=$RPM_BUILD_ROOT \
45         installdirs=vendor
46 ./Build
47
48 %{?with_tests:./Build test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 ./Build install
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/Module/Build/Deprecated.pm
62 %{perl_vendorlib}/Module/Build/ModuleInfo.pm
63 %{perl_vendorlib}/Module/Build/Version.pm
64 %{perl_vendorlib}/Module/Build/YAML.pm
65 %{_mandir}/man3/Module::Build::Deprecated.3pm*
66 %{_mandir}/man3/Module::Build::ModuleInfo.3pm*
67 %{_mandir}/man3/Module::Build::Version.3pm*
68 %{_mandir}/man3/Module::Build::YAML.3pm*
This page took 0.081616 seconds and 4 git commands to generate.