]> git.pld-linux.org Git - packages/perl-Mixin-Linewise.git/blob - perl-Mixin-Linewise.spec
- pl, rpm macros for perl dependency generators
[packages/perl-Mixin-Linewise.git] / perl-Mixin-Linewise.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Mixin
6 %define         pnam    Linewise
7 Summary:        Mixin::Linewise - write your linewise code for handles; this does the rest
8 Summary(pl.UTF-8):      Mixin::Linewise - wystarczy napisać kod liniowy dla uchwytów; ten moduł zrobi resztę
9 Name:           perl-Mixin-Linewise
10 Version:        0.110
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/Mixin-Linewise-%{version}.tar.gz
16 # Source0-md5:  466b2b42a0cec2b163729fa581ac4b1d
17 Patch0:         version.patch
18 URL:            https://metacpan.org/dist/Mixin-Linewise
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-PerlIO-utf8_strict
24 BuildRequires:  perl-Sub-Exporter
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 It's boring to deal with opening files for I/O, converting strings to
31 handle-like objects, and all that. With Mixin::Linewise::Readers and
32 Mixin::Linewise::Writers, you can just write a method to handle
33 handles, and methods for handling strings and filenames are added for
34 you.
35
36 %description -l pl.UTF-8
37 Czynności związane z otwieraniem plików do we/wy, przekształcaniem
38 łańcuchów na obiekty uchwytów itd. są nudne. Dzięki
39 Mixin::Linewise::Readers i Mixin::Linewise::Writers wystarczy napisać
40 metodę obsługującą uchwyty, a metody do obsługi łańcuchów i nazw
41 plików zostaną dodane za programistę.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 %patch0 -p1
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %dir %{perl_vendorlib}/Mixin
67 %{perl_vendorlib}/Mixin/Linewise.pm
68 %{perl_vendorlib}/Mixin/Linewise
69 %{_mandir}/man3/Mixin::Linewise*.3pm*
This page took 0.078626 seconds and 4 git commands to generate.