]> git.pld-linux.org Git - packages/perl-Math-Vec.git/blame - perl-Math-Vec.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-Vec.git] / perl-Math-Vec.spec
CommitLineData
bbcf5ee0 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
bbcf5ee0 5%define pdir Math
6%define pnam Vec
7Summary: Math::Vec - Object-Oriented Vector Math Methods in Perl
8d156cf6 8Summary(pl.UTF-8): Math::Vec - zorientowane obiektowo metody do wektorów w Perlu
bbcf5ee0 9Name: perl-Math-Vec
f8f1c7dc 10Version: 1.01
bbcf5ee0 11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
8d156cf6 15Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
f8f1c7dc 16# Source0-md5: 3d881e6f8074257d54125190719859eb
8d156cf6 17URL: http://search.cpan.org/dist/Math-Vec/
bbcf5ee0 18BuildRequires: perl-Module-Build
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This module was adapted from Math::Vector, written by Wayne M.
26Syvinski.
27
28It uses most of the same algorithms, and currently preserves the same
29names as the original functions, though some aliases have been added
30to make the interface more natural (at least to the way I think.)
31
32The "object" for the object oriented calling style is a blessed array
33reference which contains a vector of the form [x,y,z]. Methods will
34typically return a list.
35
8d156cf6
JB
36%description -l pl.UTF-8
37Ten moduł został zaadaptowany z Math::Vector napisanego przez Wayne'a
38M. Syvinskiego.
39
40Używa w większości tych samych algorytmów i aktualnie zachowuje te
41same nazwy jak funkcje oryginalne, ale dodano trochę aliasów, aby
42uczynić interfejs bardziej naturalnym (przynajmniej zdaniem autora).
43
44"Obiekt" dla zorientowanego obiektowo stylu wywołań jest
45pobłogosławioną referencją do tablicy zawierającą wektor w postaci
46[x,y,z]. Metody zwykle zwracają listę.
47
bbcf5ee0 48%prep
49%setup -q -n %{pdir}-%{pnam}-%{version}
50
51%build
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor \
54 destdir=$RPM_BUILD_ROOT
55./Build
56
57%{?with_tests:./Build test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62./Build install
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc README
70%{perl_vendorlib}/Math/Vec.pm
71%{_mandir}/man3/*
This page took 0.084274 seconds and 4 git commands to generate.