]> git.pld-linux.org Git - packages/perl-Math-Spline.git/blob - perl-Math-Spline.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-Spline.git] / perl-Math-Spline.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    Spline
7 Summary:        Math::Spline - Cubic Spline Interpolation of data
8 Summary(pl.UTF-8):      Math::Spline - interpolacja danych splajnami kubicznymi
9 Name:           perl-Math-Spline
10 Version:        0.01
11 Release:        13
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a9ebe29ba1794d1dca60aa0c44178197
17 Patch0:         %{name}-man.patch
18 URL:            http://search.cpan.org/dist/Math-Spline/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Math-Derivative
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This package provides cubic spline interpolation of numeric data. The
29 data is passed as references to two arrays containing the x and y
30 ordinates. It may be used as an exporter of the numerical functions
31 or, more easily as a class module.
32
33 %description -l pl.UTF-8
34 Ten pakiet udostępnia interpolację danych numerycznych przy pomocy
35 splajnów kubicznych. Dane są przekazywane jako referencje do dwóch
36 tablic zawierających współrzędne x i y. Moduł może być używany do
37 eksportowania funkcji numerycznych albo, łatwiej, jako klasa.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 %patch0 -p0
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %{perl_vendorlib}/Math/Spline.pm
63 %{_mandir}/man3/*
This page took 0.061013 seconds and 3 git commands to generate.