]> git.pld-linux.org Git - packages/perl-Math-Prime-XS.git/blob - perl-Math-Prime-XS.spec
perl 5.38.0 rebuild
[packages/perl-Math-Prime-XS.git] / perl-Math-Prime-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define pdir    Math
7 %define pnam    Prime-XS
8 Summary:        Math::Prime::XS - Calculate/detect prime numbers with deterministic tests
9 Name:           perl-Math-Prime-XS
10 Version:        0.26_01
11 Release:        12
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b93a438fd10640b47910be8f9c3403ba
17 URL:            http://search.cpan.org/dist/Math-Prime-XS/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with autodeps} || %{with tests}
21 BuildRequires:  perl-boolean
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Math::Prime::XS calculates/detects prime numbers by either applying
27 Modulo operator division, the Sieve of Eratosthenes, Trial division or
28 a Summing calculation.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34         #config="optimize='%{rpmcflags}'" \
35 %{__perl} Build.PL \
36         destdir=$RPM_BUILD_ROOT \
37         installdirs=vendor
38 ./Build
39
40 %{?with_tests:./Build test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 ./Build install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes INSTALL README
53 %dir %{perl_vendorarch}/Math/Prime
54 %{perl_vendorarch}/Math/Prime/XS.pm
55 %dir %{perl_vendorarch}/auto/Math/Prime
56 %dir %{perl_vendorarch}/auto/Math/Prime/XS
57 %attr(755,root,root) %{perl_vendorarch}/auto/Math/Prime/XS/*.so
58 %{_mandir}/man3/*
This page took 0.102486 seconds and 3 git commands to generate.