]> git.pld-linux.org Git - packages/perl-Math-NumSeq.git/blob - perl-Math-NumSeq.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-NumSeq.git] / perl-Math-NumSeq.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    NumSeq
7 Summary:        Math::NumSeq -- number sequences
8 Name:           perl-Math-NumSeq
9 Version:        71
10 Release:        2
11 License:        GPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  c3d6104e4ce98cbb2b46239ed258c2cf
15 URL:            http://search.cpan.org/dist/Math-NumSeq/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl(Math::Factor::XS) >= 0.40
20 BuildRequires:  perl(Math::Prime::XS) >= 0.23
21 BuildRequires:  perl-constant-defer >= 1
22 BuildRequires:  perl-File-HomeDir
23 BuildRequires:  perl-Math-Libm
24 BuildRequires:  perl-Module-Util
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a base class for some number sequences.  Sequence objects can
31 iterate through values and some sequences have random access and/or a
32 predicate test.
33
34 The idea is to generate things like squares or primes in a generic way.
35 Some sequences, like squares, are so easy there's no need for a class except
36 for the genericness.  Other sequences are trickier and an iterator is a good
37 way to go through values.  The iterating tries to be progressive, so not
38 calculating too far ahead yet doing reasonable size chunks for efficiency.
39
40 Sequence values have an integer index "i" starting either from i=0 or i=1 or
41 whatever best suits the sequence.  The values can be anything, positive,
42 negative, fractional, etc.
43
44 The intention is that all modules Math::NumSeq::Foo are sequence classes,
45 and that supporting things are deeper, such as under
46 Math::NumSeq::Something::Helper or Math::NumSeq::Base::SharedStuff.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes
75 %{perl_vendorlib}/Math/NumSeq
76 %{perl_vendorlib}/Math/NumSeq.pm
77 %{_mandir}/man3/*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.084891 seconds and 4 git commands to generate.