]> git.pld-linux.org Git - packages/perl-Math-GMP.git/blob - perl-Math-GMP.spec
- tabs in preamble
[packages/perl-Math-GMP.git] / perl-Math-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    GMP
8 Summary:        Math::GMP Perl module - high speed arbitrary size integer math
9 Summary(pl.UTF-8):      Moduł Perla Math::GMP - szybka arytmetyka liczb całkowitych o dowolnym rozmiarze
10 Name:           perl-Math-GMP
11 Version:        2.04
12 Release:        1
13 License:        LGPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  291e5847986c7591cd70c1788c979a98
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  gmp-devel
19 BuildRequires:  rpmbuild(macros) >= 1.213
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::GMP gives you access to the fast GMP library for fast big
25 integer math.
26
27 %description -l pl.UTF-8
28 Math::GMP daje dostęp do szybkiej biblioteki GMP dla szybkich
29 obliczeń na dużych liczbach całkowitych.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
35 # original reference values expect 32-bit long
36 %{__perl} -pi -e 's/^\+9999999999(9*):[0-9]+$/+9999999999$1:9999999999$1/' t/gmppm.t
37 %endif
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes LICENSE README
59 %{perl_vendorarch}/Math/GMP.pm
60 %dir %{perl_vendorarch}/auto/Math/GMP
61 %{perl_vendorarch}/auto/Math/GMP/GMP.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GMP/GMP.so
63 %{perl_vendorarch}/auto/Math/GMP/autosplit.ix
64 %{_mandir}/man3/*
This page took 0.067822 seconds and 4 git commands to generate.