]> git.pld-linux.org Git - packages/perl-Math-GMP.git/blob - perl-Math-GMP.spec
- rel 5
[packages/perl-Math-GMP.git] / perl-Math-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    GMP
8 Summary:        Math::GMP Perl module - high speed arbitrary size integer math
9 Summary(pl.UTF-8):      Moduł Perla Math::GMP - szybka arytmetyka liczb całkowitych o dowolnym rozmiarze
10 Name:           perl-Math-GMP
11 Version:        2.06
12 Release:        5
13 License:        LGPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0ead0cd7d7ec1076c6d5a5fbe81b91a3
17 URL:            http://search.cpan.org/dist/Math-GMP/
18 BuildRequires:  gmp-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.213
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Math::GMP gives you access to the fast GMP library for fast big
26 integer math.
27
28 %description -l pl.UTF-8
29 Math::GMP daje dostęp do szybkiej biblioteki GMP dla szybkich
30 obliczeń na dużych liczbach całkowitych.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
36 # original reference values expect 32-bit long
37 %{__perl} -pi -e 's/^\+9999999999(9*):[0-9]+$/+9999999999$1:9999999999$1/' t/gmppm.t
38 %endif
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes LICENSE README
61 %{perl_vendorarch}/Math/GMP.pm
62 %dir %{perl_vendorarch}/auto/Math/GMP
63 %{perl_vendorarch}/auto/Math/GMP/GMP.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GMP/GMP.so
65 %{perl_vendorarch}/auto/Math/GMP/autosplit.ix
66 %{_mandir}/man3/*
This page took 0.082 seconds and 4 git commands to generate.