]> git.pld-linux.org Git - packages/perl-Math-GMP.git/blob - perl-Math-GMP.spec
c52896cd364a3251b257392d55f704fd4963b4a9
[packages/perl-Math-GMP.git] / perl-Math-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    GMP
8 Summary:        Math::GMP Perl module - high speed arbitrary size integer math
9 Summary(pl.UTF-8):      Moduł Perla Math::GMP - szybka arytmetyka liczb całkowitych o dowolnym rozmiarze
10 Name:           perl-Math-GMP
11 Version:        2.17
12 Release:        2
13 License:        LGPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f06e26dbf1a4836b55c47252ae66e33d
17 URL:            http://search.cpan.org/dist/Math-GMP/
18 BuildRequires:  gmp-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-Devel-CheckLib
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.213
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Math::GMP gives you access to the fast GMP library for fast big
27 integer math.
28
29 %description -l pl.UTF-8
30 Math::GMP daje dostęp do szybkiej biblioteki GMP dla szybkich
31 obliczeń na dużych liczbach całkowitych.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
37 # original reference values expect 32-bit long
38 %{__perl} -pi -e 's/^\+9999999999(9*):[0-9]+$/+9999999999$1:9999999999$1/' t/gmppm.t
39 %endif
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes LICENSE README
62 %{perl_vendorarch}/Math/GMP.pm
63 %dir %{perl_vendorarch}/auto/Math/GMP
64 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GMP/GMP.so
65 %{perl_vendorarch}/auto/Math/GMP/autosplit.ix
66 %{_mandir}/man3/*
This page took 0.053472 seconds and 2 git commands to generate.