]> git.pld-linux.org Git - packages/perl-Math-Base-Convert.git/blob - perl-Math-Base-Convert.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-Base-Convert.git] / perl-Math-Base-Convert.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    Base-Convert
7 Summary:        Math::Base::Convert - very fast base to base conversion
8 Summary(pl.UTF-8):      Math::Base::Convert - bardzo szybka konwersja podstawy systemu liczenia
9 Name:           perl-Math-Base-Convert
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aed8356d8e2870ee1d27a7b6c5752714
17 URL:            http://search.cpan.org/dist/Math-Base-Convert/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 # diagnostics module requires perldiag.pod
22 BuildRequires:  perl-perldoc
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides fast functions and methods to convert between
29 arbitrary number bases from 2 (binary) thru 65535.
30
31 This module is pure Perl, has no external dependencies, and is
32 backward compatible with old versions of Perl 5.
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia szybkie funkcje i metody do konwersji między
36 dowolnymi podstawami systemu liczenia od 2 (binarnego) do 65535.
37
38 Ten moduł jest napisany w czystym Perlu i jest zgodny ze starszymi
39 wersjami Perla 5.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes
63 %dir %{perl_vendorlib}/Math/Base
64 %{perl_vendorlib}/Math/Base/Convert.pm
65 %{perl_vendorlib}/Math/Base/Convert
66 %{_mandir}/man3/Math::Base::Convert*.3pm*
This page took 0.07268 seconds and 4 git commands to generate.