]> git.pld-linux.org Git - packages/perl-Makefile-Parser.git/blame - perl-Makefile-Parser.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Makefile-Parser.git] / perl-Makefile-Parser.spec
CommitLineData
ded13d2e
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Makefile
6%define pnam Parser
ded13d2e
JB
7Summary: Makefile::Parser - A simple parser for Makefiles
8Summary(pl.UTF-8): Makefile::Parser - prosty analizator plików Makefile
9Name: perl-Makefile-Parser
10Version: 0.215
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/A/AG/AGENT/Makefile-Parser-%{version}.tar.gz
16# Source0-md5: f80b65da36c3fd004c8b7067e99c2c9f
17Patch0: %{name}-test.patch
18URL: http://search.cpan.org/dist/Makefile-Parser/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRequires: sed >= 4.0
22%if %{with tests}
23BuildRequires: perl-Class-Accessor
24BuildRequires: perl-Class-Trigger >= 0.13
25BuildRequires: perl-File-Slurp
26BuildRequires: perl-IPC-Run3 >= 0.036
27BuildRequires: perl-List-MoreUtils
28BuildRequires: perl-Makefile-DOM >= 0.005
29%endif
30Requires: perl-Class-Trigger >= 0.13
31Requires: perl-IPC-Run3 >= 0.036
32Requires: perl-Makefile-DOM >= 0.005
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This is a simple parser for Makefiles. At this very early stage, the
38parser only supports a limited set of features, so it may not
39recognize most of the advanced features provided by certain make tools
40like GNU make. Its initial purpose is to provide basic support for
41another module named Makefile::GraphViz, which is aimed to render the
42building process specified by a Makefile using the amazing GraphViz
43library.
44
45%description -l pl.UTF-8
46Ten pakiet to prosty analizator plików Makefile. Na wstępnym etapie
47obsługuje tylko ograniczony zbiór możliwości, więc może nie
48rozpoznawać większości zaawansowanych możliwości niektórych
49implementacji make, takich jak GNU make. Pierwotnym celem jest
50zapewnienie podstawowej obsługi dla innego modułu -
51Makefile::GraphViz, którego celem jest renderowanie procesu budowania
52opisanego plikiem Makefile przy użyciu biblioteki GraphViz.
53
54%prep
55%setup -q -n %{pdir}-%{pnam}-%{version}
56%patch0 -p1
57
58%{__sed} -i -e '1s,/usr/bin/env perl,/usr/bin/perl,' script/*
59
60%build
61%{__perl} Makefile.PL \
62 INSTALLDIRS=vendor
63%{__make}
64
65%{?with_tests:%{__make} test}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%{__make} pure_install \
71 DESTDIR=$RPM_BUILD_ROOT
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc Changes README
79%attr(755,root,root) %{_bindir}/makesimple
80%attr(755,root,root) %{_bindir}/pgmake-db
81%attr(755,root,root) %{_bindir}/plmake
82%{perl_vendorlib}/Makefile/AST.pm
83%{perl_vendorlib}/Makefile/AST
84%{perl_vendorlib}/Makefile/Parser.pm
85%{perl_vendorlib}/Makefile/Parser
86%{_mandir}/man1/makesimple.1p*
87%{_mandir}/man1/pgmake-db.1p*
88%{_mandir}/man1/plmake.1p*
89%{_mandir}/man3/Makefile::AST*.3pm*
90%{_mandir}/man3/Makefile::Parser*.3pm*
This page took 0.097949 seconds and 4 git commands to generate.