]> git.pld-linux.org Git - packages/perl-Mail-Transport.git/blob - perl-Mail-Transport.spec
- new
[packages/perl-Mail-Transport.git] / perl-Mail-Transport.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    Transport
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mail::Transport - use Mail Transfer Agents (MTAs)
9 Name:           perl-Mail-Transport
10 Version:        3.004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6294dc02c2a75e0b0f21fa16a4493f28
17 URL:            https://metacpan.org/release/Mail-Transport/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Mail-Message >= 3
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Objects which extend Mail::Transport implement sending and/or
28 receiving of messages, using various protocols.
29
30 Mail::Transport::Send extends this class, and offers general
31 functionality for send protocols, like SMTP.  Mail::Transport::Receive
32 also extends this class, and offers receive method.  Some transport
33 protocols will implement both sending and receiving.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc ChangeLog README
57 %{perl_vendorlib}/Mail/*.pm
58 %{perl_vendorlib}/Mail/Transport
59 %{_mandir}/man3/*
This page took 0.10871 seconds and 4 git commands to generate.