]> git.pld-linux.org Git - packages/perl-Mail-SPF.git/blob - perl-Mail-SPF.spec
- fix noauto req
[packages/perl-Mail-SPF.git] / perl-Mail-SPF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    SPF
7 Summary:        Mail::SPF - Mail Sender Authentication
8 Summary(pl.UTF-8):      Mail::SPF - uwierzytelnianie wysyłającego pocztę
9 Name:           perl-Mail-SPF
10 Version:        2.9.0
11 Release:        4
12 # "same as perl"
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-v%{version}.tar.gz
16 # Source0-md5:  664e20d79c87fa505080f362e827dace
17 Patch0:         tests-fix.patch
18 URL:            http://search.cpan.org/dist/Mail-SPF/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Net-DNS >= 0.58
24 BuildRequires:  perl-NetAddr-IP
25 BuildRequires:  perl-version
26 BuildRequires:  perl-Net-DNS-Resolver-Programmable
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreq_perl         Mail::SPF::GlobalMod
32
33 %description
34 This is an initial draft object oriented reimplementation of
35 Mail::SPF::Query. It is not yet fully tested, and does not yet contain
36 all of the additional features expected of a practical SPF
37 implementation.
38
39 %description -l pl.UTF-8
40 To jest początkowa zorientowana obiektowo reimplementacja
41 Mail::SPF::Query. Nie jest jeszcze w pełni przetestowana i nie zawiera
42 jeszcze wszystkich dodatkowych możliwości oczekiwanych od praktycznej
43 implementacji SPF.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-v%{version}
47 %patch0 -p1
48
49 # These tests mess around with resolv.conf and networking
50 # that are not present on builders
51 %{__rm} t/00.04-class-server.t t/00.05-class-macrostring.t
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/spfquery
73 %attr(755,root,root) %{_sbindir}/spfd
74 %{perl_vendorlib}/Mail/SPF.pm
75 %dir %{perl_vendorlib}/Mail/SPF
76 %{perl_vendorlib}/Mail/SPF/*.pm
77 %dir %{perl_vendorlib}/Mail/SPF/Mech
78 %{perl_vendorlib}/Mail/SPF/Mech/*.pm
79 %{perl_vendorlib}/Mail/SPF/Mod
80 %{perl_vendorlib}/Mail/SPF/v1
81 %{perl_vendorlib}/Mail/SPF/v2
82 %{_mandir}/man1/*
83 %{_mandir}/man3/*
This page took 0.089405 seconds and 4 git commands to generate.