3 %bcond_without tests # do not perform "make test"
7 Summary: Mail::SPF::Query - Perl implementation of SPF
8 Summary(pl.UTF-8): Mail::SPF::Query - perlowa implementacja SPF
9 Name: perl-Mail-SPF-Query
13 License: GPL v1+ or Artistic
14 Group: Development/Languages/Perl
15 Source0: http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5: 6d62d024d1614fa1fa4f43bd39ee7bf0
18 URL: http://search.cpan.org/dist/Mail-SPF-Query/
20 BuildRequires: perl-Net-CIDR-Lite >= 0.15
21 BuildRequires: perl-Net-DNS >= 0.33
22 BuildRequires: perl-Sys-Hostname-Long
23 BuildRequires: perl-Test-Simple
24 BuildRequires: perl-URI
26 BuildRequires: perl-devel >= 1:5.8.0
27 BuildRequires: rpm-perlprov >= 4.1-13
28 BuildRequires: rpmbuild(macros) >= 1.268
29 Requires: perl(URI::Escape) >= 3.20
30 Requires: perl-Net-CIDR-Lite >= 0.15
31 Requires: perl-Net-DNS >= 0.33
32 Requires: perl-Sys-Hostname-Long
34 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37 This module implements a daemon to query SPF records for email forgery
40 %description -l pl.UTF-8
41 Ten moduł jest implementacją demona sprawdzającego rekordy SPF w celu
42 wykrywania sfałszowanej poczty.
45 Summary: SPF record checking daemon
46 Summary(pl.UTF-8): Demon sprawdzający rekordy SPF
47 Group: Networking/Daemons
48 Requires(post,preun): /sbin/chkconfig
49 Requires: %{name} = %{version}-%{release}
53 SPF record checking daemon, operating as a local resolver on
56 %description -n spfd -l pl.UTF-8
57 Demon sprawdzający rekordy SPF, działający jako lokalny resolver na
61 %setup -q -n %{pdir}-%{pnam}-%{version}
64 %{__perl} Makefile.PL \
68 %{?with_tests:%{__make} test}
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
75 DESTDIR=$RPM_BUILD_ROOT
77 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/spfd
79 # we prefer spfquery from perl-Mail-SPF
80 rm -rf $RPM_BUILD_ROOT{%{_bindir}/spfquery,%{_mandir}/man1/spfquery*}
83 rm -rf $RPM_BUILD_ROOT
86 /sbin/chkconfig --add spfd
87 %service spfd restart "SPF daemon"
90 if [ "$1" = "0" ]; then
92 /sbin/chkconfig --del spfd
96 %defattr(644,root,root,755)
97 %doc CHANGES README examples
98 %dir %{perl_vendorlib}/Mail/SPF
99 %{perl_vendorlib}/Mail/SPF/*.pm
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_bindir}/spfd
105 %attr(754,root,root) /etc/rc.d/init.d/spfd
106 %{_mandir}/man1/spfd*