]> git.pld-linux.org Git - packages/perl-Mail-ListDetector.git/blob - perl-Mail-ListDetector.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-ListDetector.git] / perl-Mail-ListDetector.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Mail
6 %define         pnam    ListDetector
7 Summary:        Mail::ListDetector - Perl extension for detecting mailing list messages
8 Summary(pl.UTF-8):      Mail::ListDetector - rozszerzenie Perla do wykrywania poczty z list dyskusyjnych
9 Name:           perl-Mail-ListDetector
10 Version:        1.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ab3554c5bd87cf22dc720b0847780c77
17 URL:            http://search.cpan.org/dist/Mail-ListDetector/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Email-Abstract
22 BuildRequires:  perl-Email-Valid
23 %endif
24 Requires:       perl-Email-Valid
25 Requires:       perl-URI
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module analyzes Mail::Internet objects. It returns a
31 Mail::ListDetector::List object representing the mailing list.
32
33 The RFC2369 mailing list detector is also capable of matching some
34 Mailman and Ezmlm messages.
35
36 %description -l pl.UTF-8
37 Ten moduł analizuje obiekty Mail::Internet. Zwraca obiekt
38 Mail::ListDetector::List, reprezentujący listę dyskusyjną.
39
40 Zgodny z RFC2369 kod do rozpoznawania list jest także zdolny do
41 wyłapywania części wiadomości, produkowanych przez programy Mailman i
42 Ezmlm.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install -D examples/sample.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/sample.pl
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Change* AUTHORS BUGS README TODO
68 %{perl_vendorlib}/Mail/*.pm
69 %{perl_vendorlib}/Mail/ListDetector
70 # empty autosplit.ix
71 %{perl_vendorlib}/auto/Mail/ListDetector
72 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
73 %{_mandir}/man3/*
This page took 0.069885 seconds and 4 git commands to generate.