]> git.pld-linux.org Git - packages/perl-Mail-Box-POP3.git/blob - perl-Mail-Box-POP3.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-Box-POP3.git] / perl-Mail-Box-POP3.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    Box-POP3
7 Summary:        Mail::Box::POP3 - handle POP3 folders as client
8 #Summary(pl.UTF-8):
9 Name:           perl-Mail-Box-POP3
10 Version:        3.004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bb67146e3b3367db3714363f2f0d9698
17 #URL:           https://metacpan.org/release/Mail-Box-POP3/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Mail::Box::Net) >= 3
22 BuildRequires:  perl(Mail::Box::Test) >= 3
23 BuildRequires:  perl(Mail::Transport::Receive) >= 3
24 BuildRequires:  perl-Mail-Message >= 3
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Maintain a folder which has its messages stored on a remote server.
31 The communication between the client application and the server is
32 implemented using the POP3 protocol. This class uses
33 Mail::Transport::POP3 to hide the transport of information, and
34 focusses solely on the correct handling of messages within a POP3
35 folder.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog README
59 %{perl_vendorlib}/Mail/Box/POP3.pm
60 %{perl_vendorlib}/Mail/Box/POP3.pod
61 %{perl_vendorlib}/Mail/Box/POP3s.pm
62 %{perl_vendorlib}/Mail/Box/POP3s.pod
63 %{perl_vendorlib}/Mail/Box/POP3
64 %{perl_vendorlib}/Mail/Transport/POP3.pm
65 %{perl_vendorlib}/Mail/Transport/POP3.pod
66 %{_mandir}/man3/*
This page took 0.118271 seconds and 3 git commands to generate.