]> git.pld-linux.org Git - packages/perl-Mail-Box-IMAP4.git/blob - perl-Mail-Box-IMAP4.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-Box-IMAP4.git] / perl-Mail-Box-IMAP4.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    Box-IMAP4
7 Summary:        Mail::Transport::IMAP4 - proxy to Mail::IMAPClient
8 Name:           perl-Mail-Box-IMAP4
9 Version:        3.003
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  e195c24962425a14afb7841b5f2e33ba
16 URL:            https://metacpan.org/release/Mail-Box-IMAP4/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Mail::Box::Manage::User) >= 3
21 BuildRequires:  perl(Mail::Box::Net) >= 3
22 BuildRequires:  perl(Mail::Box::Search) >= 3
23 BuildRequires:  perl(Mail::Box::Test) >= 3
24 BuildRequires:  perl(Mail::Message::Head::Delayed) >= 3
25 BuildRequires:  perl(Mail::Server) >= 3
26 BuildRequires:  perl(Mail::Transport::Receive) >= 3
27 BuildRequires:  perl-Digest-HMAC
28 BuildRequires:  perl-Mail-IMAPClient
29 BuildRequires:  perl-Mail-Message >= 3
30 BuildRequires:  perl-TimeDate
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The IMAP4 protocol is quite complicated: it is feature rich and allows
37 various asynchronous actions. The main document describing IMAP is
38 rfc3501 (which obsoleted the original specification of protocol 4r1 in
39 rfc2060 in March 2003).
40
41 This package, as part of MailBox, does not implement the actual
42 protocol itself but uses Mail::IMAPClient to do the work. The task for
43 this package is to hide as many differences between that module's
44 interface and the common MailBox folder types. Multiple
45 Mail::Box::IMAP4 folders can share one Mail::Transport::IMAP4
46 connection.
47
48 The Mail::IMAPClient module is the best IMAP4 implementation for
49 Perl5, but is not maintained. There are many known problems with the
50 module, and solving those is outside the scope of MailBox. See
51 http://rt.cpan.org/Public/Dist/Display.html?Name=Mail-IMAPClient for
52 all the reported bugs.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc ChangeLog README
76 %{perl_vendorlib}/Mail/Box/*.pm
77 %{perl_vendorlib}/Mail/Box/*.pod
78 %{perl_vendorlib}/Mail/Box/IMAP4
79 %{perl_vendorlib}/Mail/Server/IMAP4.pm
80 %{perl_vendorlib}/Mail/Server/IMAP4.pod
81 %dir %{perl_vendorlib}/Mail/Server/IMAP4
82 %{perl_vendorlib}/Mail/Server/IMAP4/*.pm
83 %{perl_vendorlib}/Mail/Server/IMAP4/*.pod
84 %{perl_vendorlib}/Mail/Transport/IMAP4.pm
85 %{perl_vendorlib}/Mail/Transport/IMAP4.pod
86 %{_mandir}/man3/*
This page took 0.041388 seconds and 4 git commands to generate.