]> git.pld-linux.org Git - packages/perl-MP3-Tag.git/blob - perl-MP3-Tag.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MP3-Tag.git] / perl-MP3-Tag.spec
1 # ToDo:
2 # - include tk-tag/tk-tag.pl or not? Maybe as a seperate package (more R:)?
3 #
4 # Conditional build:
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         pdir    MP3
8 %define         pnam    Tag
9 #
10 Summary:        Module for reading/writing tags of MP3 audio files
11 Summary(pl.UTF-8):      Moduł do odczytywania/zapisywania znaczników z plików MP3
12 Name:           perl-MP3-Tag
13 Version:        1.13
14 Release:        3
15 License:        Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  1eea17c9c8a03433634eb37fc16311d3
19 URL:            http://search.cpan.org/dist/MP3-Tag/
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.21-3
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl-Encode >= 2.44-2
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a Perl module to read/write ID3v1, ID3v1.1 and ID3v2.3 tags of
29 MP3 files. (Other tags hopefully to follow).
30
31 %description -l pl.UTF-8
32 Moduł Perla służący do odczytywania/zapisywania znaczników MP3 typu
33 ID3v1, ID3v1.1 oraz ID3v2.3 (inne znaczniki w przyszłości).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README.txt
61 %attr(755,root,root) %{_bindir}/audio_rename
62 %attr(755,root,root) %{_bindir}/mp3info2
63 %attr(755,root,root) %{_bindir}/typeset_audio_dir
64 %{perl_vendorlib}/Encode/transliterate_win1251.pm
65 %dir %{perl_vendorlib}/Normalize
66 %dir %{perl_vendorlib}/Normalize/Text
67 %{perl_vendorlib}/Normalize/Text/Music_Fields.pm
68 %{perl_vendorlib}/MP3/*.pm
69 %{perl_vendorlib}/MP3/Tag
70 %{_mandir}/man1/*
71 %{_mandir}/man3/*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.069488 seconds and 4 git commands to generate.