]> git.pld-linux.org Git - packages/perl-LockFile-Simple.git/blob - perl-LockFile-Simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-LockFile-Simple.git] / perl-LockFile-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    LockFile
6 %define         pnam    Simple
7 Summary:        LockFile::Simple Perl module - simple file locking scheme
8 Summary(pl.UTF-8):      Moduł Perla LockFile::Simple - prosty schemat blokowania plików
9 Name:           perl-LockFile-Simple
10 Version:        0.207
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  194573bdf3f1823723959b25f0a322d0
16 URL:            http://search.cpan.org/dist/LockFile-Simple/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LockFile::Simple Perl module - provides simple locking scheme which is
24 not based on any file locking system calls such as "flock()" or
25 "lockf()" but rather relies on basic file system primitives and
26 properties, such as the atomicity of the "write()" system call. It is
27 not meant to be exempt from all race conditions, especially over NFS.
28
29 %description -l pl.UTF-8
30 Moduł Perla LockFile::Simple - udostępnia prosty system blokowania
31 plików nie oparty na żadnych funkcjach systemowych, takich jak
32 "flock()" i "lockf()" służących do blokowania plików. Korzysta on z
33 podstawowych własności systemów plików, takich jak atomowość funkcji
34 systemowej "write()". Nie oznacza to, że jest on wolny od sytuacji
35 "wyścigu" (race conditions), zwłaszcza w przypadku korzystania z NFS.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog README
59 %{perl_vendorlib}/LockFile/*.pm
60 %{perl_vendorlib}/LockFile/Lock
61 %{_mandir}/man3/*
This page took 0.077483 seconds and 3 git commands to generate.