]> git.pld-linux.org Git - packages/perl-Linux-Smaps.git/blob - perl-Linux-Smaps.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Linux-Smaps.git] / perl-Linux-Smaps.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Linux
6 %define pnam    Smaps
7 Summary:        Linux::Smaps - a Perl interface to /proc/PID/smaps
8 Summary(pl.UTF-8):      Linux::Smaps - perlowy interfejs do /proc/PID/smaps
9 Name:           perl-Linux-Smaps
10 Version:        0.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/O/OP/OPI/Linux-Smaps-%{version}.tar.gz
16 # Source0-md5:  d8a3abec9265a0e583844dc7952e9134
17 URL:            http://search.cpan.org/~opi/Linux-Smaps/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Member) >= 1.3
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The /proc/PID/smaps files in modern linuxes provides very detailed
28 information about a processes memory consumption. It particularly
29 includes a way to estimate the effect of copy-on-write.
30 This module implements a Perl interface.
31
32 %description -l pl.UTF-8
33 Pliki /proc/PID/smaps w nowych linuksach dostarczają bardzo
34 szczegółowych informacji dotyczących zyżycia pamięci przez
35 procesy.
36 Ten moduł dostarcza interfejs perlowy do tych plików.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Linux/*.pm
61 %{_mandir}/man3/*
This page took 0.087721 seconds and 4 git commands to generate.