]> git.pld-linux.org Git - packages/perl-Lingua-EN-Fathom.git/blob - perl-Lingua-EN-Fathom.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Lingua-EN-Fathom.git] / perl-Lingua-EN-Fathom.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Lingua
6 %define         pnam    EN-Fathom
7 Summary:        Lingua::EN::Fathom - Measure readability of English text
8 Summary(pl.UTF-8):      Lingua::EN::Fathom - określanie czytelności tekstu angielskiego
9 Name:           perl-Lingua-EN-Fathom
10 Version:        1.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Lingua/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  94bd7ecf1f9b460fb090f478a39acdfd
17 URL:            http://search.cpan.org/dist/Lingua-EN-Fathom/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Lingua-EN-Syllable
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module analyses English text in either a string or file. Totals
28 are then calculated for the number of characters, words, sentences,
29 blank and non blank (text) lines and paragraphs.
30
31 Three common readability statistics are also derived, the Fog, Flesch
32 and Kincaid indices.
33
34 All of these properties can be accessed through individual methods, or
35 by generating a text report.
36
37 A hash of all unique words and the number of times they occur is
38 generated.
39
40 %description -l pl.UTF-8
41 Ten moduł analizuje tekst angielski pochodzący z łańcucha znaków lub
42 pliku. Następnie wylicza podsumowanie liczby znaków, słów, zdań oraz
43 pustych i niepustych (zawierających tekst) wierszy oraz akapitów.
44
45 Liczone są także trzy popularne statystyki czytelności: Foga, Flescha
46 oraz Kincaida.
47
48 Wszystkie te właściwości można odczytywać poprzez osobne metody lub
49 generując raport tekstowy.
50
51 Generowany jest także hasz wszystkich unikalnych słów oraz liczby ich
52 wystąpień.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %{__perl} -pi -e 's,/usr/local/bin/perl,/usr/bin/perl,' examples/*.pl
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} pure_install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73 cp -a examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes
81 %{perl_vendorlib}/Lingua/EN/Fathom.pm
82 %{_mandir}/man3/Lingua::EN::Fathom.3pm*
83 %dir %{_examplesdir}/%{name}-%{version}
84 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.237249 seconds and 4 git commands to generate.