]> git.pld-linux.org Git - packages/perl-LWP-Protocol-http10.git/blob - perl-LWP-Protocol-http10.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-LWP-Protocol-http10.git] / perl-LWP-Protocol-http10.spec
1 # Conditional build:
2 %bcond_without  tests           # do not perform "make test"
3 #
4 %define         pdir    LWP
5 %define         pnam    Protocol-http10
6 Summary:        LWP::Protocol::http10 - Legacy HTTP/1.0 support for LWP
7 #Summary(pl.UTF-8):     
8 Name:           perl-LWP-Protocol-http10
9 Version:        6.03
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  c3d2f6efc2ce06066cf95a24fed6fff1
16 # add this for completeness, resurrected from libwww sources
17 # http://cpansearch.perl.org/src/GAAS/libwww-perl-6.01/lib/LWP/Protocol/https10.pm
18 Source1:        https10.pm
19 URL:            http://search.cpan.org/dist/LWP-Protocol-http10/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The LWP::Protocol::http10 module provide support for using HTTP/1.0
27 protocol with LWP.  To use it you need to call
28 LWP::Protocol::implementor() to override the standard handler for
29 http URLs.
30
31 This module used to be bundled with the libwww-perl, but it was
32 unbundled in v6.02 as part of the general cleanup for the 6-series.
33 LWP::Protocol::http10 is deprecated.
34
35 # %description -l pl.UTF-8
36 # TODO
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{perl_vendorlib}/LWP/Protocol
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/LWP/Protocol/http10.pm
64 %{perl_vendorlib}/LWP/Protocol/https10.pm
65 %{_mandir}/man3/*
66
67 %changelog
This page took 0.069549 seconds and 4 git commands to generate.