]> git.pld-linux.org Git - packages/perl-LWP-Online.git/blob - perl-LWP-Online.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-LWP-Online.git] / perl-LWP-Online.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    LWP
6 %define         pnam    Online
7 Summary:        LWP::Online - Does your process have access to the web
8 Name:           perl-LWP-Online
9 Version:        1.08
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  20e25b3af8b84a493c730249c2a9c50d
16 URL:            http://search.cpan.org/dist/LWP-Online/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-URI >= 1.35
21 BuildRequires:  perl-libwww >= 5.805
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module attempts to answer, as accurately as it can, one of the
28 nastiest technical questions there is.
29
30 Am I on the internet?
31
32 The answer is useful in a wide range of decisions. For example...
33
34 Should my test scripts run the online portion of the tests or just
35 skip them?
36
37 Do I try to fetch fresh data from the server?
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/LWP/Online.pm
62 %{_mandir}/man3/LWP::Online.3pm*
This page took 0.073375 seconds and 4 git commands to generate.