]> git.pld-linux.org Git - packages/perl-LWP-MediaTypes.git/blob - perl-LWP-MediaTypes.spec
- updated dependencies
[packages/perl-LWP-MediaTypes.git] / perl-LWP-MediaTypes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    LWP
6 %define         pnam    MediaTypes
7 Summary:        LWP::MediaTypes - guess media type for a file or a URL
8 Summary(pl.UTF-8):      LWP::MediaTypes - zgadywanie typu zawartości dla pliku lub URL-a
9 Name:           perl-LWP-MediaTypes
10 Version:        6.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  84b799a90c0d2ce52897a7cb4c0478d0
17 URL:            https://metacpan.org/release/LWP-MediaTypes
18 %if %{with tests}
19 BuildRequires:  perl-Scalar-List-Utils
20 BuildRequires:  perl-Test-Fatal
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.8
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  rpmbuild(macros) >= 1.745
26 Conflicts:      perl-libwww < 6
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module provides functions for handling media (also known as MIME)
32 types and encodings. The mapping from file extensions to media types
33 is defined by the media.types file. If the ~/.media.types file exists
34 it is used instead. For backwards compatibility the module will also
35 look for ~/.mime.types.
36
37 %description -l pl.UTF-8
38 Ten moduł udostępnia funkcje do obsługi typów zawartości (znanych też
39 jako typy MIME) plików oraz ich kodowań. Odwzorowanie rozszerzeń
40 plików na typy zawartości jest definiowane w pliku media.types; jeśli
41 istnieje plik ~/.media.types, jest on używany zamiast domyślnego
42 pliku. Dla kompatybilności wstecznej moduł sprawdza także plik
43 ~/.mime.types.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %dir %{perl_vendorlib}/LWP
68 %{perl_vendorlib}/LWP/MediaTypes.pm
69 %{perl_vendorlib}/LWP/media.types
70 %{_mandir}/man3/LWP::MediaTypes.3pm*
This page took 0.137411 seconds and 4 git commands to generate.