]> git.pld-linux.org Git - packages/perl-JSON.git/blob - perl-JSON.spec
Up to 4.10
[packages/perl-JSON.git] / perl-JSON.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define pdir    JSON
6 Summary:        JSON - parse and convert to JSON (JavaScript Object Notation)
7 Summary(pl.UTF-8):      JSON - analiza i konwersja do notacji JSON (JavaScript Object Notation)
8 Name:           perl-JSON
9 Version:        4.10
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/JSON/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  a709b32e194d0eb38f788cb49f422c4e
16 URL:            https://metacpan.org/dist/JSON
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 Suggests:       perl-JSON-XS
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module converts between JSON (JavaScript Object Notation) and
26 Perl data structure into each other.
27
28 For JSON, See to <http://www.crockford.com/JSON/>.
29
30 %description -l pl.UTF-8
31 Ten moduł dokonuje konwersji między notacją JSON (JavaScript Object
32 Notation) a perlowymi strukturami danych.
33
34 Więcej informacji na temat notacji JSON można znaleźć pod adresem
35 <http://www.crockford.com/JSON/>.
36
37 %prep
38 %setup -q -n %{pdir}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/JSON.pm
61 %{perl_vendorlib}/JSON
62 %{_mandir}/man3/JSON*.3pm*
This page took 0.131402 seconds and 3 git commands to generate.