]> git.pld-linux.org Git - packages/perl-Image-Imlib2.git/blob - perl-Image-Imlib2.spec
perl 5.38.0 rebuild
[packages/perl-Image-Imlib2.git] / perl-Image-Imlib2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Image
6 %define         pnam    Imlib2
7 Summary:        Interface to the Imlib2 image library
8 Summary(pl.UTF-8):      Interfejs do biblioteki obrazów Imlib2
9 Name:           perl-Image-Imlib2
10 Version:        2.03
11 Release:        14
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Image/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  303b91fae2b863903e41a3cac34fa0d3
17 Patch0:         pc.patch
18 URL:            http://search.cpan.org/dist/Image-Imlib2/
19 BuildRequires:  imlib2-devel
20 BuildRequires:  perl-Module-Build >= 0.20
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Image::Imlib2 is a Perl port of Imlib2, a graphics library that does
28 image file loading and saving as well as manipulation, arbitrary
29 polygon support, etc. It does ALL of these operations FAST. It allows
30 you to create colour images using a large number of graphics
31 primitives, and output the images in a range of formats.
32
33 %description -l pl.UTF-8
34 Image::Imlib2 to perlowy port Imlib2 - biblioteki graficznej
35 wczytującej, zapisującej i przetwarzającej obrazy z obsługą dowolnych
36 wielokątów itp. Wykonuje WSZYSTKIE te operacje SZYBKO. Pozwala na
37 tworzenie kolorowych obrazów przy użyciu dużej liczby prymitywów
38 graficznych i zapis ich w wielu formatach.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor \
47         destdir=$RPM_BUILD_ROOT
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 cd examples
62 for f in * ; do
63         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
64                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
65 done
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGES README
73 %{perl_vendorarch}/Image/Imlib2.pm
74 %dir %{perl_vendorarch}/auto/Image/Imlib2
75 %attr(755,root,root) %{perl_vendorarch}/auto/Image/Imlib2/*.so
76 %dir %{_examplesdir}/%{name}-%{version}
77 %{_examplesdir}/%{name}-%{version}/*.txt
78 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
79 %{_mandir}/man3/Image::Imlib2*.3pm*
This page took 0.096763 seconds and 4 git commands to generate.