]> git.pld-linux.org Git - packages/perl-IPC-Shareable.git/blob - perl-IPC-Shareable.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IPC-Shareable.git] / perl-IPC-Shareable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %define         pdir    IPC
6 %define         pnam    Shareable
7 Summary:        IPC::Shareable - share Perl variables between processes
8 Summary(pl.UTF-8):      IPC::Shareable - współdzielenie zmiennych Perla między procesami
9 Name:           perl-IPC-Shareable
10 Version:        0.60
11 Release:        6
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  51462dabfb4eec81e0b3417a9f9add4e
16 URL:            http://search.cpan.org/dist/IPC-Shareable/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IPC::Shareable allows you to tie a variable to shared memory making it
24 easy to share the contents of that variable with other Perl processes.
25 Scalars, arrays, and hashes can be tied. The variable being tied may
26 contain arbitrarily complex data structures - including references to
27 arrays, hashes of hashes, etc.
28
29 %description -l pl.UTF-8
30 Moduł IPC::Shareable pozwala związać zmienną z pamięcią dzieloną, co
31 ułatwia współdzielenie zawartości tej zmiennej z innymi procesami
32 Perla. Wiązane mogą być skalary, tablice i hasze. Powiązana zmienna
33 może zawierać dowolnie skomplikowane struktury danych - włączenie z
34 referencjami do tablic, haszy haszy itd.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %{__perl} -pi -e 's/^(require 5.005)(03;)$/$1_$2/' ./lib/IPC/Shareable.pm
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES CREDITS DISCLAIMER README TO_DO
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{perl_vendorlib}/%{pdir}/%{pnam}
64 %{_examplesdir}/%{name}-%{version}
65 %{_mandir}/man3/*
This page took 0.119326 seconds and 4 git commands to generate.