]> git.pld-linux.org Git - packages/perl-IO-Socket-Socks.git/blob - perl-IO-Socket-Socks.spec
- fix shebangs in scripts
[packages/perl-IO-Socket-Socks.git] / perl-IO-Socket-Socks.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    Socket-Socks
7 Summary:        IO::Socket::Socks - provides a way to create socks client or server both 4 and 5 version
8 Summary(pl.UTF-8):      IO::Socket::Socks - tworzenie klienta i serwera SOCKS w wersji 4 i 5
9 Name:           perl-IO-Socket-Socks
10 Version:        0.74
11 Release:        2
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  9b19fba551ae14aa2382bfe318245de2
16 URL:            http://search.cpan.org/dist/IO-Socket-Socks/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IO::Socket::Socks connects to a SOCKS proxy, tells it to open a
24 connection to a remote host/port when the object is created. The
25 object you receive can be used directly as a socket (with IO::Socket
26 interface) for sending and receiving data from the remote host. In
27 addition to create socks client this module could be used to create
28 socks server.
29
30 %description -l pl.UTF-8
31 IO::Socket::Socks łączy się do proxy SOCKS i mówi mu, żeby połączył
32 się ze zdalnym hostem. Obiekt tego typu można użyć wprost jako socket
33 (z interfejsem IO::Socket) do wysyłania i pobierania danych ze
34 zdalnego hosta. Dodatkowo, poza możliwością tworzenia klienta SOCKS,
35 można również utworzyć serwer SOCKS.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' examples/*.pl
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 %{__cp} examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/IO/Socket/Socks.pm
66 %{_mandir}/man3/*
67 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.145474 seconds and 4 git commands to generate.