]> git.pld-linux.org Git - packages/perl-IO-Socket-INET6.git/blob - perl-IO-Socket-INET6.spec
- updated URL and macros, added tests
[packages/perl-IO-Socket-INET6.git] / perl-IO-Socket-INET6.spec
1 #
2 # Conditional build
3 %bcond_without  tests   # unit tests
4
5 %define pdir    IO
6 %define pnam    Socket-INET6
7 Summary:        IO::Socket::INET6 - Object interface for AF_INET|AF_INET6 domain sockets
8 Summary(pl.UTF-8):      IO::Socket::INET6 - obiektowy interfejs do gniazd z domen AF_INET|AF_INET6
9 Name:           perl-IO-Socket-INET6
10 Version:        2.72
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  510ddc1bd75a8340ca7226123fb545c1
17 URL:            https://metacpan.org/release/IO-Socket-INET6
18 %if %{with tests}
19 BuildRequires:  perl-Socket6 >= 0.12
20 BuildRequires:  perl-Test-Simple
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 IO::Socket::INET6 provides an object interface to creating and using
30 sockets in either AF_INET or AF_INET6 domains. It is built upon the
31 IO::Socket interface and inherits all the methods defined by
32 IO::Socket.
33
34 %description -l pl.UTF-8
35 IO::Socket::INET6 udostępnia obiektowy interfejs do tworzenia i
36 używania gniazd z rodziny AF_INET oraz AF_INET6. Jest zbudowany w
37 opaciu o interfejs IO::Socket i dziedziczy wszystkie metody
38 definiowane przez IO::Socket.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %if %{with test}
49 %{__make} test
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog README
64 %{perl_vendorlib}/IO/Socket/INET6.pm
65 %{_mandir}/man3/IO::Socket::INET6.3pm*
This page took 0.119343 seconds and 4 git commands to generate.