]> git.pld-linux.org Git - packages/perl-IO-LockedFile.git/blob - perl-IO-LockedFile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-LockedFile.git] / perl-IO-LockedFile.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %define pdir    IO
6 %define pnam    LockedFile
7 Summary:        IO::LockedFile - supply object methods for locking files
8 Summary(pl.UTF-8):      IO::LockedFile - metody obiektów do blokowania blików
9 Name:           perl-IO-LockedFile
10 Version:        0.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f447f67ac7c9f42d86d07ca7477cdec6
17 URL:            http://search.cpan.org/dist/IO-LockedFile/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 In its simplistic use, the IO::LockedFile class gives us the same
25 interface of the IO::File class with the unique difference that the
26 files we deal with are locked using the Flock mechanism (using the
27 flock function).
28
29 %description -l pl.UTF-8
30 W najprostszym zastosowaniu klasa IO::LockedFile udostępnia ten sam
31 interfejs, co klasa IO::File z jedyną różnicą polegającą na tym, że
32 pliki są blokowane przy użyciu mechanizmu Flock (przy użyciu funkcji
33 flock).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/IO/*.pm
58 %{perl_vendorlib}/IO/LockedFile
59 %{_mandir}/man3/*
This page took 0.082035 seconds and 3 git commands to generate.