]> git.pld-linux.org Git - packages/perl-IO-Digest.git/blob - perl-IO-Digest.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-Digest.git] / perl-IO-Digest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IO
6 %define         pnam    Digest
7 Summary:        IO::Digest - calculate digests while reading or writing
8 Summary(pl.UTF-8):      IO::Digest - wyliczanie sum kontrolnych podczas odczytu lub zapisu
9 Name:           perl-IO-Digest
10 Version:        0.10
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0448841e0559c2c19c7e8001ef087e26
17 Patch0:         %{name}-noninteractive.patch
18 URL:            http://search.cpan.org/dist/IO-Digest/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-PerlIO-via-dynamic
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The IO::Digest Perl module allows you to calculate digests while
29 reading or writing file handles. This avoids the case you need to
30 reread the same content to compute the digests after written a file.
31
32 %description -l pl.UTF-8
33 Moduł Perla IO::Digest umożliwia wyliczanie sum kontrolnych podczas
34 odczytu z lub zapisu do pliku. Pozwala to uniknąć ponownego odczytu
35 tej samej zawartości przy obliczaniu sum kontrolnych po zapisie do
36 pliku.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES README
61 %{perl_vendorlib}/IO/Digest.pm
62 %{_mandir}/man3/*
This page took 0.06762 seconds and 4 git commands to generate.