]> git.pld-linux.org Git - packages/perl-IO-Compress-Lzop.git/blob - perl-IO-Compress-Lzop.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-Compress-Lzop.git] / perl-IO-Compress-Lzop.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    IO
6 %define pnam    Compress-Lzop
7 Summary:        Modules to read/write lzop files/buffers
8 Summary(pl.UTF-8):      Moduły do odczytu/zapisu plików/buforów lzop
9 Name:           perl-IO-Compress-Lzop
10 Version:        2.074
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f8a67fb13d2ccafeec9c3f36689b817b
17 URL:            http://search.cpan.org/dist/IO-Compress-Lzop/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 5.16
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Compress-LZO
23 BuildRequires:  perl-IO-Compress >= %{version}
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 IO::Compress::Lzop and IO::Uncompress::UnLzop modules provide a Perl
30 interface that allows reading and writing lzop compressed data from/to
31 files or buffer.
32
33 %description -l pl.UTF-8
34 Moduły IO::Compress::Lzop i IO::Uncompress::UnLzop udostępniają
35 perlowy interfejs umożliwiający odczyt i zapis danych skompresowanych
36 algorytmem lzop z/do plików lub buforów.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/IO/Compress/Adapter/LZO.pm
61 %{perl_vendorlib}/IO/Compress/Lzop.pm
62 %{perl_vendorlib}/IO/Compress/Lzop
63 %{perl_vendorlib}/IO/Uncompress/Adapter/LZO.pm
64 %{perl_vendorlib}/IO/Uncompress/UnLzop.pm
65 %{_mandir}/man3/IO::Compress::Lzop.3pm*
66 %{_mandir}/man3/IO::Uncompress::UnLzop.3pm*
This page took 0.083201 seconds and 4 git commands to generate.