]> git.pld-linux.org Git - packages/perl-HTTP-Server-Simple.git/blob - perl-HTTP-Server-Simple.spec
- unified spec
[packages/perl-HTTP-Server-Simple.git] / perl-HTTP-Server-Simple.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests
4 #
5 %define pdir    HTTP
6 %define pnam    Server-Simple
7 Summary:        HTTP::Server::Simple - Lightweight HTTP server
8 Summary(pl.UTF-8):      HTTP::Server::Simple - lekki serwer HTTP
9 Name:           perl-HTTP-Server-Simple
10 Version:        0.52
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/authors/id/B/BP/BPS/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1e23935491d9a2a8b0ba636462255656
17 URL:            https://metacpan.org/dist/HTTP-Server-Simple
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a simple standalone HTTP server. By default, it doesn't thread
26 or fork. It does, however, act as a simple frontend which can be used
27 to build a standalone web-based application or turn a CGI into one.
28 It's possible to use Net::Server to get threading, forking, preforking
29 and so on. Autrijus Tang wrote the functionality and owes docs for
30 that.
31
32 %description -l pl.UTF-8
33 HTTP::Server::Simple jest prostym, samodzielnym serwerem HTTP.
34 Domyślnie nie obsługuje on wątków i podprocesów, jednakże może
35 byc użyty jako frontend do budowy samodzielnej aplikacji WWW lub jako
36 CGI. Możliwe jest użycie modułu Net::Server do obsługi wątków,
37 podprocesów itp. z wykorzystaniem kodu stworzonego przez Autrijusa
38 Tanga.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/HTTP/Server
63 %{_mandir}/man3/HTTP::Server::*.3pm*
This page took 0.186584 seconds and 4 git commands to generate.