]> git.pld-linux.org Git - packages/perl-HTTP-Request-AsCGI.git/blob - perl-HTTP-Request-AsCGI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTTP-Request-AsCGI.git] / perl-HTTP-Request-AsCGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    HTTP
6 %define pnam    Request-AsCGI
7 Summary:        HTTP::Request::AsCGI - Setup a CGI environment from a HTTP::Request
8 Summary(pl.UTF-8):      HTTP::Request::AsCGI - ustawianie środowiska CGI z HTTP::Request
9 Name:           perl-HTTP-Request-AsCGI
10 Version:        1.2
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  82f4749a702992d405d2a8f8118e87ec
17 URL:            http://search.cpan.org/dist/HTTP-Request-AsCGI/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Accessor
22 BuildRequires:  perl-libwww >= 5.805
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Provides a convinient way of setting up an CGI environment from a
29 HTTP::Request.
30
31 %description -l pl.UTF-8
32 Ten moduł udostępnia łatwą metodę ustawiania środowiska CGI z
33 HTTP::Request.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/HTTP/Request/*.pm
61 %{_mandir}/man3/*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.086178 seconds and 4 git commands to generate.