]> git.pld-linux.org Git - packages/perl-HTTP-Headers-ActionPack.git/blob - perl-HTTP-Headers-ActionPack.spec
- initial
[packages/perl-HTTP-Headers-ActionPack.git] / perl-HTTP-Headers-ActionPack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    HTTP
6 %define         pnam    Headers-ActionPack
7 Summary:        HTTP::Headers::ActionPack - HTTP Action, Adventure and Excitement
8 Name:           perl-HTTP-Headers-ActionPack
9 Version:        0.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d0d2cb37e259cc0449f7883202356654
16 URL:            https://metacpan.org/release/HTTP-Headers-ActionPack
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-HTTP-Date
22 BuildRequires:  perl-HTTP-Message
23 BuildRequires:  perl-Module-Runtime
24 BuildRequires:  perl-Sub-Exporter
25 BuildRequires:  perl-Test-Fatal >= 0.0003
26 BuildRequires:  perl-Test-Warnings
27 BuildRequires:  perl-URI
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is a module to handle the inflation and deflation of complex HTTP
34 header types. In many cases header values are simple strings, but in
35 some cases they are complex values with a lot of information encoded
36 in them. The goal of this module is to make the parsing and analysis
37 of these headers as easy as calling inflate on a compatible object
38 (see below for a list).
39
40 This top-level class is basically a Factory for creating instances of
41 the other classes in this module. It contains a number of convenience
42 methods to help make common cases easy to write.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes INSTALL README
69 %{perl_vendorlib}/HTTP/Headers/*.pm
70 %{perl_vendorlib}/HTTP/Headers/ActionPack
71 %{_mandir}/man3/*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.116537 seconds and 4 git commands to generate.