]> git.pld-linux.org Git - packages/perl-HTTP-Exception.git/blob - perl-HTTP-Exception.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTTP-Exception.git] / perl-HTTP-Exception.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    HTTP
6 %define         pnam    Exception
7 Summary:        HTTP::Exception - throw HTTP-Errors as (Exception::Class-) Exceptions
8 Name:           perl-HTTP-Exception
9 Version:        0.03001
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  3541f70932c99c0c44a1d0666bfec151
16 URL:            http://search.cpan.org/dist/HTTP-Exception/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Exception-Class >= 1.29
22 BuildRequires:  perl-HTTP-Message >= 5.817
23 BuildRequires:  perl-Test-Exception >= 0.29
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Every HTTP::Exception is a Exception::Class - Class. So the same
30 mechanisms apply as with Exception::Class-classes. In fact have a look
31 at Exception::Class' docs for more general information on exceptions
32 and Exception::Class::Base for information on what methods a caught
33 exception also has.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         destdir=$RPM_BUILD_ROOT \
41         installdirs=vendor
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/HTTP/*.pm
58 %{perl_vendorlib}/HTTP/Exception
59 %{_mandir}/man3/*
This page took 0.088962 seconds and 4 git commands to generate.