]> git.pld-linux.org Git - packages/perl-HTTP-Date.git/blob - perl-HTTP-Date.spec
- updated to 6.05
[packages/perl-HTTP-Date.git] / perl-HTTP-Date.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    HTTP
6 %define         pnam    Date
7 Summary:        HTTP::Date - date conversion routines
8 Summary(pl.UTF-8):      HTTP::Date - funkcje do konwersji dat
9 Name:           perl-HTTP-Date
10 Version:        6.05
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2ecbb3aedf6aef062605191813ca3027
17 URL:            https://metacpan.org/release/HTTP-Date
18 %if %{with tests}
19 BuildRequires:  perl(Time::Local) >= 1.28
20 BuildRequires:  perl-Test-Simple
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.8
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 Conflicts:      perl-libwww < 6
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides functions that deal the date formats used by the
31 HTTP protocol (and then some more).  Only the first two functions,
32 time2str() and str2time(), are exported by default.
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia funkcje obsługujące formaty danych używane w
36 protokole HTTP (i paru innych). Domyślnie eksportowane są tylko dwie
37 funkcje: time2str() i str2time().
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/HTTP/Date.pm
62 %{_mandir}/man3/HTTP::Date.3pm*
This page took 0.061274 seconds and 4 git commands to generate.