]> git.pld-linux.org Git - packages/perl-HTTP-Cookies.git/blob - perl-HTTP-Cookies.spec
up to 6.10
[packages/perl-HTTP-Cookies.git] / perl-HTTP-Cookies.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    HTTP
6 %define         pnam    Cookies
7 Summary:        HTTP::Cookies - HTTP cookie jars
8 Summary(pl.UTF-8):      HTTP::Cookies - pojemnik na ciasteczka HTTP
9 Name:           perl-HTTP-Cookies
10 Version:        6.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b4d7804231b1dfd10999d42283e0cf06
17 URL:            https://metacpan.org/release/HTTP-Cookies
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-HTTP-Date >= 6
23 BuildRequires:  perl-HTTP-Message >= 6
24 BuildRequires:  perl-Test-Simple
25 BuildRequires:  perl-URI
26 %endif
27 Requires:       perl-HTTP-Date >= 6
28 Requires:       perl-HTTP-Message >= 6
29 Conflicts:      perl-libwww < 6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This class is for objects that represent a "cookie jar" -- that is, a
35 database of all the HTTP cookies that a given LWP::UserAgent object
36 knows about.
37
38 This module implements the old style cookies as well as the new style
39 cookies described in RFC 2965.
40
41 Instances of the class HTTP::Cookies are able to store a collection
42 of Set-Cookie2: and Set-Cookie: headers and are able to use this
43 information to initialize Cookie-headers in HTTP::Request objects.
44 The state of a HTTP::Cookies object can be saved in and restored from
45 files.
46
47 %description -l pl.UTF-8
48 Klasa HTTP::Cookies jest przeznaczona dla obiektów reprezentujących
49 "pojemniki na ciasteczka" - tzn. bazę danych wszystkich ciasteczek
50 HTTP, jakie zna dany obiekt LWP::UserAgent.
51
52 Ten moduł implementuje ciasteczka starego typu, jak i nowego,
53 opisanego w RFC 2965.
54
55 Instancje klasy HTTP::Cookies mogą przechowywać zbiór nagłówków
56 Set-Cookie2: oraz Set-Cookie: i wykorzystywać te informacje do
57 zainicjowania nagłówków Cookie w obiektach HTTP::Request. Stan
58 obiektu HTTP::Cookies można zapisać w pliku, a później z niego
59 odtworzyć.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} pure_install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CONTRIBUTORS Changes
83 %{perl_vendorlib}/HTTP/Cookies.pm
84 %{perl_vendorlib}/HTTP/Cookies
85 %{_mandir}/man3/HTTP::Cookies*.3pm*
This page took 0.113857 seconds and 4 git commands to generate.