]> git.pld-linux.org Git - packages/perl-HTML-Widget.git/blob - perl-HTML-Widget.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTML-Widget.git] / perl-HTML-Widget.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    HTML
6 %define pnam    Widget
7 Summary:        HTML::Widget - HTML Widget And Validation Framework
8 Summary(pl.UTF-8):      HTML::Widget - szkielet widgetów i kontroli poprawności HTML-a
9 Name:           perl-HTML-Widget
10 Version:        1.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  62f582be030a322b225ced8f03012905
17 URL:            http://search.cpan.org/dist/HTML-Widget/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Accessor
22 BuildRequires:  perl-Class-Accessor-Chained
23 BuildRequires:  perl-Class-Data-Accessor
24 BuildRequires:  perl-Date-Calc
25 BuildRequires:  perl-Email-Valid
26 BuildRequires:  perl-HTML-Tree
27 BuildRequires:  perl-HTML-Scrubber
28 BuildRequires:  perl-Module-Pluggable-Fast
29 BuildRequires:  perl-Test-NoWarnings
30 BuildRequires:  perl-Test-Pod-Coverage
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Create easy to maintain HTML widgets!
37
38 Everything is optional, use validation only or just generate forms,
39 you can embed and merge them later.
40
41 The API was designed similar to other popular modules like
42 Data::FormValidator and FormValidator::Simple,
43 HTML::FillInForm is also built in (and much faster).
44
45 This module is very powerful, don't misuse it as a template system!
46
47 %description -l pl.UTF-8
48 Moduł do tworzenia łatwych w utrzymianiu widgetów HTML.
49
50 Wszystko jest opcjonalne, można używać tylko kontroli poprawności lub
51 tylko tworzyć formularze; można osadzać je i włączać później.
52
53 API zostało zaprojektowane na podobieństwo innych popularnych modułów,
54 takich jak Data::FormValidator i FormValidator::Simple;
55 HTML::FillInForm jest także wbudowany (i dużo szybszy).
56
57 Ten moduł jest naprawdę potężny, nie należy go nadużywać jako systemu
58 szablonów!
59
60 %prep
61 %setup -q -n %{pdir}-%{pnam}-%{version}
62
63 %build
64 %{__perl} Makefile.PL \
65         INSTALLDIRS=vendor
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes README
85 %{perl_vendorlib}/HTML/*.pm
86 %{perl_vendorlib}/HTML/Widget
87 %{_mandir}/man3/*
88 %{_examplesdir}/%{name}-%{version}
This page took 0.108322 seconds and 4 git commands to generate.