]> git.pld-linux.org Git - packages/perl-HTML-TagReader.git/blob - perl-HTML-TagReader.spec
up to 1.13
[packages/perl-HTML-TagReader.git] / perl-HTML-TagReader.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    TagReader
7 Summary:        HTML::TagReader - reading HTML/SGML/XML files by tags
8 Summary(pl.UTF-8):      HTML::TagReader - czytanie plików HTML/SGML/XML po znaczniku
9 Name:           perl-HTML-TagReader
10 Version:        1.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8bfaae5b6c2e66e9cd1a12e46bb97e63
17 URL:            http://search.cpan.org/dist/HTML-TagReader/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 # for tr_imgaddsize
21 Requires:       perl-Image-Size >= 2.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The module implements a fast and small object oriented way of
26 processing any kind of HTML/SGML/XML files by tag.
27
28 The getbytoken(0) is similar to while(<>) but instead of reading lines
29 it reads tags or tags and text.
30
31 HTML::TagReader makes it easy to keep track of the line number in a
32 file even though you are not reading the file by line. This important
33 if you want to implement error messages about HTML errors in your
34 code.
35
36 %description -l pl.UTF-8
37 Ten moduł implementuje szybką, obiektowo zorientowaną metodę
38 przetwarzania dowolnego rodzaju plików HTML/SGML/XML po znaczniku.
39
40 getbytoken(0) jest podobne do while(<>), ale zamiast czytania linii
41 czyta znaczniki lub znaczniki i tekst.
42
43 HTML::TagReader umożliwia łatwe śledzenie numeru linii w pliku nawet
44 jeśli nie jest on czytany po linii. Jest to ważne przy implementowaniu
45 komunikatów błędów dotyczących HTML-a.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %attr(755,root,root) %{_bindir}/tr_*
73 %{perl_vendorarch}/HTML/TagReader.pm
74 %dir %{perl_vendorarch}/auto/HTML/TagReader
75 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/TagReader/TagReader.so
76 %{_mandir}/man[13]/*
This page took 0.111783 seconds and 4 git commands to generate.