]> git.pld-linux.org Git - packages/perl-HTML-Mason.git/blob - perl-HTML-Mason.spec
UP to 1.59
[packages/perl-HTML-Mason.git] / perl-HTML-Mason.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    Mason
7 Summary:        Mason Perl module - high-performance, dynamic web site authoring system
8 Summary(pl.UTF-8):      Moduł Perla Mason - wysokowydajny system do tworzenia dynamicznych stron WWW
9 Name:           perl-HTML-Mason
10 Version:        1.59
11 Release:        1
12 Epoch:          3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e9229057cbfb2f104bf2a59848e14580
18 URL:            http://www.masonhq.com/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(File::Spec) >= 0.8
24 BuildRequires:  perl(Scalar::Util) >= 1.01
25 BuildRequires:  perl-CGI >= 2.46
26 BuildRequires:  perl-Cache-Cache >= 1.0
27 BuildRequires:  perl-Class-Container >= 0.07
28 BuildRequires:  perl-Exception-Class >= 1.14
29 BuildRequires:  perl-HTML-Parser
30 BuildRequires:  perl-Log-Any
31 BuildRequires:  perl-Params-Validate >= 0.70
32 BuildRequires:  perl-Test-Deep
33 %endif
34 Requires:       perl(File::Spec) >= 0.8
35 Requires:       perl-Class-Container >= 0.07
36 Requires:       perl-Exception-Class >= 1.14
37 Requires:       perl-Params-Validate >= 0.70
38 Conflicts:      perl-Apache-Filter < 1.021
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _noautoreq_perl Cache::Cache HTML::Mason::Exceptions HTML::Mason::MethodMaker(read_write) Apache Apache::Constants Apache::Request
43
44 %description
45 Mason is a tool for building, serving and managing large web sites.
46 Its features make it an ideal backend for high load sites serving
47 dynamic content, such as online newspapers or database driven
48 e-commerce sites.
49
50 %description -l pl.UTF-8
51 Mason jest narzędziem służącym do budowania i udostępniania dużych
52 serwisów WWW oraz do zarządzania nimi. Ze względu na swe możliwości,
53 jest idealną bazą dla dużych serwisów o dynamicznie generowanej
54 zawartości, np. gazet internetowych czy sklepów internetowych opartych
55 na bazach danych.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MasonX
74
75 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/HTML/Mason/*.pod
76
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78 gzip -9nf samples/README
79 cp -a {samples,eg} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80 mv bin contrib
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes README.md UPGRADE CREDITS contrib
88 %attr(755,root,root) %{_bindir}/*.pl
89 %{perl_vendorlib}/HTML/Mason.pm
90 %{perl_vendorlib}/HTML/Mason
91 %{_examplesdir}/%{name}-%{version}
92 # don't package bundle man page
93 %{_mandir}/man3/HTML*
94 %{perl_vendorlib}/MasonX
This page took 0.095843 seconds and 4 git commands to generate.