]> git.pld-linux.org Git - packages/perl-Growl-GNTP.git/blob - perl-Growl-GNTP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Growl-GNTP.git] / perl-Growl-GNTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Growl
6 %define         pnam    GNTP
7 Summary:        Growl::GNTP - Perl implementation of GNTP Protocol (Client Part)
8 Name:           perl-Growl-GNTP
9 Version:        0.20
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Growl/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  482e242fc8d274d1138c361200e0b65d
16 URL:            http://search.cpan.org/dist/Growl-GNTP/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(IO::Socket::PortState)
22 BuildRequires:  perl-Crypt-CBC >= 2.29
23 BuildRequires:  perl-Data-UUID >= 0.149
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Growl::GNTP is Perl implementation of GNTP Protocol (Client Part)
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Build.PL \
36         destdir=$RPM_BUILD_ROOT \
37         installdirs=vendor
38 ./Build
39
40 %{?with_tests:./Build test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 ./Build install
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %dir %{perl_vendorlib}/Growl
57 %{perl_vendorlib}/Growl/GNTP.pm
58 %{_mandir}/man3/*
59 %{_examplesdir}/%{name}-%{version}
This page took 0.061424 seconds and 4 git commands to generate.