]> git.pld-linux.org Git - packages/perl-GnuPG.git/blob - perl-GnuPG.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-GnuPG.git] / perl-GnuPG.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    GnuPG
6 Summary:        GnuPG - Perl module interface to the GNU Privacy Guard
7 Summary(pl.UTF-8):      GnuPG - moduł interfejsu perlowego do GPG (GNU Privacy Guard)
8 Name:           perl-GnuPG
9 Version:        0.18
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
14 # Source0-md5:  86f1a79389a0bede2db6bd758b464b8b
15 URL:            http://www.gnupg.org/
16 BuildRequires:  gnupg
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 GnuPG is a Perl interface to the GNU Privacy Guard. It uses the shared
24 memory coprocess interface that gpg provides for its wrappers. It
25 tries its best to map the interactive interface of the gpg to a more
26 programmatic model.
27
28 %description -l pl.UTF-8
29 GnuPG to interfejs Perla do GPG (GNU Privacy Guard). Używa interfejsu
30 pamięci dzielonej, udostępnianego przez gpg. Próbuje jak najlepiej
31 odwzorować interaktywny interfejs gpg do bardziej programistycznego
32 modelu.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:TEST_SHARED_MEMORY=1 TEST_FILE_CACHE=1 %{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/%{pdir}/
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README NEWS
58 %{perl_vendorlib}/*.pm
59 %{perl_vendorlib}/%{pdir}/Tie*
60 %attr(755,root,root) %{_bindir}/*
61 %{_mandir}/man1/*
62 %{_mandir}/man3/*
This page took 0.058567 seconds and 4 git commands to generate.