]> git.pld-linux.org Git - packages/perl-GnuPG-Interface.git/blob - perl-GnuPG-Interface.spec
- more tests BRs
[packages/perl-GnuPG-Interface.git] / perl-GnuPG-Interface.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    GnuPG
6 %define         pnam    Interface
7 Summary:        GnuPG::Interface - Perl interface to GnuPG
8 Summary(pl.UTF-8):      GnuPG::Interface - perlowy interfejs do GnuPG
9 Name:           perl-GnuPG-Interface
10 Version:        1.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/GnuPG/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3589cd8cc4b68c00e6cfd0b12daf52fc
17 URL:            http://search.cpan.org/dist/GnuPG-Interface/
18 BuildRequires:  gnupg
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-MethodMaker
23 BuildRequires:  perl-Data-Perl
24 BuildRequires:  perl-Moo
25 BuildRequires:  perl-MooX-late
26 BuildRequires:  perl-MooX-HandlesVia
27 BuildRequires:  perl-Moose
28 BuildRequires:  perl-Type-Tiny
29 %endif
30 # not recognized by perl.req
31 Requires:       perl-Class-MethodMaker
32 Requires:       perl-Mouse
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GnuPG::Interface and its associated modules are designed to provide an
38 object-oriented method for interacting with GnuPG, being able to
39 perform functions such as but not limited to encrypting, signing,
40 decryption, verification, and key-listing parsing.
41
42 %description -l pl.UTF-8
43 GnuPG::Interface i powiązane moduły powstały, by udostępnić obiektowo
44 zorientowany sposób na interakcję z GnuPG. Moduły mogą wykonywać
45 funkcje takie jak szyfrowanie, podpisywanie, odszyfrowywanie,
46 weryfikację, analizę list kluczy i inne.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:TEST_SHARED_MEMORY=1 TEST_FILE_CACHE=1 %{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/%{pdir}/%{pnam}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README MANIFEST
72 %{perl_vendorlib}/GnuPG/*.pm
73 %{_mandir}/man3/*
This page took 0.097069 seconds and 4 git commands to generate.