]> git.pld-linux.org Git - packages/perl-GD.git/blob - perl-GD.spec
perl 5.38.0 rebuild
[packages/perl-GD.git] / perl-GD.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        GD - interface to GD graphics library
6 Summary(pl.UTF-8):      GD - interfejs do biblioteki graficznej GD
7 Name:           perl-GD
8 Version:        2.76
9 Release:        3
10 License:        Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/GD/GD-%{version}.tar.gz
13 # Source0-md5:  fb4bacab10ed4f28d52c2aabdaf866bb
14 Patch0:         %{name}-paths.patch
15 URL:            https://metacpan.org/dist/GD
16 BuildRequires:  gd-devel >= 2.0.28
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  perl(ExtUtils::Constant) >= 0.22
19 BuildRequires:  perl-ExtUtils-PkgConfig
20 %if %{with tests}
21 BuildRequires:  perl-Math-Trig
22 BuildRequires:  perl-Test-Fork >= 0.02
23 BuildRequires:  perl-Test-Simple >= 0.88
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  rpmbuild(macros) >= 1.745
27 Requires:       gd >= 2.0.28
28 Provides:       perl-GD(gif) = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 GD.pm is a Perl interface to Thomas Boutell's GD graphics library. GD
33 allows you to create color drawings using a large number of graphics
34 primitives, and emit the drawings as PNG files.
35
36 %description -l pl.UTF-8
37 GD.pm jest perlowym interfejsem do biblioteki graficznej GD Thomasa
38 Boutella. GD pozwala na tworzenie kolorowych rysunków przy użyciu
39 dużej liczby graficznych prymitywów oraz zapisywanie ich w formacie
40 PNG.
41
42 %prep
43 %setup -q -n GD-%{version}
44 %patch0 -p1
45
46
47 %build
48 %{__perl} Makefile.PL </dev/null \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{perl_vendorlib}/GD}
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp -fa demos bdf_scripts \
64         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 gzip -9nf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/bdf_scripts/README
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ChangeLog README*
74 %attr(755,root,root) %{_bindir}/bdf2gdfont.pl
75 %{perl_vendorarch}/GD.pm
76 %{perl_vendorarch}/GD
77 %dir %{perl_vendorarch}/auto/GD
78 %{perl_vendorarch}/auto/GD/autosplit.ix
79 %attr(755,root,root) %{perl_vendorarch}/auto/GD/GD.so
80 %dir %{perl_vendorlib}/GD
81 %{_mandir}/man1/bdf2gdfont.pl.1*
82 %{_mandir}/man3/GD*.3pm*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.099854 seconds and 4 git commands to generate.