]> git.pld-linux.org Git - packages/perl-Future.git/blob - perl-Future.spec
- stop loading perl macros manually
[packages/perl-Future.git] / perl-Future.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pnam    Future
6 Summary:        Future - represent an operation awaiting completion
7 Name:           perl-Future
8 Version:        0.41
9 Release:        1
10 # same as perl
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://cpan.metacpan.org/authors/id/P/PE/PEVANS/%{pnam}-%{version}.tar.gz
14 # Source0-md5:  f83f2ec38a5b3f43fd91bdc886ae151b
15 URL:            http://search.cpan.org/dist/Future/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-Module-Build
19 %if %{with tests}
20 BuildRequires:  perl-Test-Identity
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A Future object represents an operation that is currently in progress,
27 or has recently completed. It can be used in a variety of ways to
28 manage the flow of control, and data, through an asynchronous program.
29
30 Some futures represent a single operation and are explicitly marked as
31 ready by calling the done or fail methods. These are called "leaf"
32 futures here, and are returned by the new constructor.
33
34 Other futures represent a collection of sub-tasks, and are implicitly
35 marked as ready depending on the readiness of their component futures
36 as required. These are called "convergent" futures here as they
37 converge control and data-flow back into one place. These are the ones
38 returned by the various wait_* and need_* constructors.
39
40 %prep
41 %setup -q -n %{pnam}-%{version}
42
43 %build
44 %{__perl} Build.PL \
45         destdir=$RPM_BUILD_ROOT \
46         installdirs=vendor
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Future.pm
63 %{perl_vendorlib}/Future
64 %{perl_vendorlib}/Test/Future.pm
65 %{perl_vendorlib}/Test/Future
66 %{_mandir}/man3/Future*.3pm*
67 %{_mandir}/man3/Test::Future*.3pm*
This page took 0.081186 seconds and 4 git commands to generate.