]> git.pld-linux.org Git - packages/perl-Filter-Template.git/blob - perl-Filter-Template.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Filter-Template.git] / perl-Filter-Template.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Filter
6 %define         pnam    Template
7 Summary:        Filter::Template - source filter for inline code templates
8 Summary(pl.UTF-8):      Filter::Template - filtr kodu źródłowego dla szablonów kodu inline
9 Name:           perl-Filter-Template
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Filter/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ea654b36d5de0f1167566690e6fce108
17 URL:            http://search.cpan.org/dist/Filter-Template/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Filter::Template is a Perl source filter that provides simple inline
25 source code templates. Inlined source code can be significantly faster
26 than subroutines, especially for small-scale functions like accessors
27 and mutators. On the other hand, they are more difficult to maintain
28 and use. Choose your trade-offs wisely.
29
30 %description -l pl.UTF-8
31 Filter::Template to filtr kodu źródłowego Perla udostępniający proste
32 szablony kodu źródłowego inline. Kod źródłowy inline może być znacząco
33 szybszy niż podprocedury, zwłaszcza dla małych funkcji takich jak
34 accessor czy mutator. Z drugiej strony są one dużo trudniejsze w
35 utrzymywaniu i używaniu. Trzeba dokonać mądrego wyboru.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES README
60 %{perl_vendorlib}/Filter/Template.pm
61 %dir %{perl_vendorlib}/Filter/Template
62 %{perl_vendorlib}/Filter/Template/UseBytes.pm
63 %{_mandir}/man3/*
This page took 0.122987 seconds and 3 git commands to generate.