]> git.pld-linux.org Git - packages/perl-FileHandle-Unget.git/blob - perl-FileHandle-Unget.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-FileHandle-Unget.git] / perl-FileHandle-Unget.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    FileHandle
6 %define pnam    Unget
7 Summary:        FileHandle::Unget - FileHandle which supports multi-byte unget
8 Summary(pl.UTF-8):      FileHandle::Unget - FileHandle który wspiera wielobajtowe zwracanie znaków
9 Name:           perl-FileHandle-Unget
10 Version:        0.1623
11 Release:        1
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/FileHandle/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  27df2a78e60e30b1950bbf41740eae13
16 URL:            http://search.cpan.org/dist/FileHandle-Unget/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 FileHandle::Unget operates exactly the same as FileHandle, except that it
27 provides a version of ungetc that allows you to unget more than one character.
28 It also provides ungets to unget a string.
29
30 This module is useful if the filehandle refers to a stream for which you can't
31 just seek() backwards. Some operating systems support multi-byte
32 ungetc(), but this is not guaranteed. Use this module if you want a
33 portable solution. In addition, on some operating systems, eof() will not be
34 reset if you ungetc after having read to the end of the file.
35
36 NOTE: Using sysread() with ungetc() and other buffering functions is
37 still a bad idea.
38
39 %description -l pl.UTF-8
40 FileHandle::Unget działa dokładnie tak samo jak FileHandle, za wyjątkiem tego,
41 że dostarcza wersję ungetc, która umożliwia na zwrócenie więcej niż jednego znaku.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGES README
65 %dir %{perl_vendorlib}/FileHandle
66 %{perl_vendorlib}/FileHandle/Unget.pm
67 %{_mandir}/man3/*
This page took 0.072559 seconds and 4 git commands to generate.