]> git.pld-linux.org Git - packages/perl-File-chmod.git/blob - perl-File-chmod.spec
- updated to 0.42
[packages/perl-File-chmod.git] / perl-File-chmod.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    chmod
7 Summary:        File::chmod - Implements symbolic and ls chmod modes
8 Summary(pl.UTF-8):      File::chmod - implementacja uprawnień symbolicznych i ls funkcji chmod
9 Name:           perl-File-chmod
10 Version:        0.42
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b94807f4bef13506ee529a214524f9de
16 URL:            https://metacpan.org/release/File-chmod
17 BuildRequires:  perl-ExtUtils-MakeMaker
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 File::chmod is a utility that allows you to bypass system calls or bit
26 processing of a file's permissions. It overloads the chmod() function
27 with its own that gets an octal mode, a symbolic mode or an "ls" mode.
28 If you wish not to overload chmod(), you can export symchmod() and
29 lschmod(), which take, respectively, a symbolic mode and an "ls" mode.
30
31 %description -l pl.UTF-8
32 File::chmod to narzędzie pozwalające na pominięcie wywołań systemowych
33 lub przetwarzania bitów uprawnień plików. Przeciąża funkcję chmod()
34 własną, która przyjmuje uprawnienia w postaci ósemkowej, symbolicznej
35 i "ls". Modułu można użyć też bez przeciążania chmod(), eksportując
36 funkcje symchmod() i lschmod, które przyjmują uprawnienia w postaci
37 odpowiednio symbolicznej i "ls".
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/File/chmod.pm
62 %{_mandir}/man3/File::chmod.3pm*
This page took 0.096667 seconds and 4 git commands to generate.